Inicio > general > Error en integración de OpenOffice-MySQL

Error en integración de OpenOffice-MySQL

Connection using old (pre-4.1.1) authentication protocol refused (client option ‘secure_auth’ enabled)” fué el mensaje que recibí cuando traté de abrir desde OpenOffice una base de datos MySQL que tengo en ejecución desde un ordenador de desarrollo. A primera vista, no me sonó familiar ese error así que busqué en Internet información que me ayudara a saber de qué se trataba.

No tuve éxito en el proceso de encontrar una respuesta.

A la hora de escribir ésta nota llega a mi cabeza una razonable explicación del error:

La base de datos MySQL en ejecución es muy vieja.

Y parece que mi hipótesis está correcta, porque:

  1. La traducción al Español del mensaje arriba mencionado sería así: Rechazada la conexión que usa el antiguo (pre-4.1.1) protocolo de autenticación (habilitada la opción ‘secure_auth’ en el cliente). Me parece que tal cosa se refiere a un conflicto en el protocolo de autenticación que usan el cliente (OpenOffice) y el servidor (MySQL).
  2. La versión de MySQL en ése ordenador de desarrollo es anterior a la 5.1. En el capítulo Sun MySQL Connector (OOo) Beta del wiki “servicios” de OpenOffice se indica que el conector Sun MySQL Connector:
    It can be used to connect from OpenOffice.org 3.1 to a MySQL server 5.1 or newer.
    es decir: Se puede usar para conectar desde OpenOffice 3.1 a un servidor MySQL 5.1 o de más nueva versión.

Agendaré la actualización de ese servidor MySQL y en cuanto esté instalado haré de nuevo el intento de conectar desde OpenOffice al nuevo servidor MySQL.

Publicaré el resultado tan pronto como pueda.

Compártelo en:
  • Digg
  • del.icio.us
  • Facebook
  • Mixx
  • Google Bookmarks
  • Technorati
  • Yahoo! Buzz
Categories: general Tags: ,
  1. No hay comentarios.
  1. No trackbacks yet.
Debe iniciar sesion para publicar un comentario.